logosmall
 
GSM# 001846
V6Sprout
V6Sprout

308

points

Roots Blown V6 Engine

updated: Jul 21st 2005 @ 07:49 AM
I am one of a few who have installed a Thunderbird Supercoupe roots blown motor in my Mustang. I was originally running a Volvo front mount intercooler but I had a leak in the endtank, so I made a custom IC out of two stock Supercoupe IC cores and made the endtanks to mimic the Volvo IC, since I already had custom piping made for the Volvo IC. The endtanks are too large and block my rad too much so my engine temps were too high but it ran good until I blew my rear main seal.

http://www.gotstang.com/photodisplay.php?file=3405
[ remotely linked image: click here ]



http://www.gotstang.com/photodisplay.php?file=3420
[ remotely linked image: click here ]



Pic of the intercooler pipes when I orginally had them done in Chrome powder, now they are smoked chrome.


[ click to enlarge ]



Now I am working on adapting the 03 Cobra blower to my V6, Below are some pics of the wooden prototype custom intake I am making, I will be welding up an aluminum version soon.

http://www.gotstang.com/photodisplay.php?file=3432
[ remotely linked image: click here ]



http://www.gotstang.com/photodisplay.php?file=3433
[ remotely linked image: click here ]



http://www.gotstang.com/photodisplay.php?file=3434
[ remotely linked image: click here ]




Next Page


 
Page Listing
Car Pics2956 views
Roots Blown V6 Engine1246 views
V6 Ford Challenge656 views
Part I have Chromed575 views
Parts I have powdercoated582 views
My Kids481 views
Me being Silly548 views
1977 F250 w/460532 views

Last 3 User Comments
silverstreak02
Jun 28th, 2009 @ 11:22 PM


“”

Thanks to all who gave me advise on what to do with the sensor. Apparently it worked. The check engine light has not come on at all. I even bought the Chilton Manual to make sure I did everything right. Thanks everyone.

silverstreak02

Torch_Vert
Jun 22nd, 2009 @ 12:43 PM


“”
Replying to:

Hey Fro,

I need some help with a little problem I have. My check engine light came on, and I ran diagnostics on it and it came back with P0401. So I replaced the EGR Valve and found out that wasn't the problem. Now I get a P0402 and I think I have it narrowed down to the pressure sensor but I need some one to confirm that for me. What do you think?

Dennis


If you've already done the EGR valve, the DPFE pressure sensor is the next likely culprit

silverstreak02
Jun 22nd, 2009 @ 12:27 PM


“”

Hey Fro,

I need some help with a little problem I have. My check engine light came on, and I ran diagnostics on it and it came back with P0401. So I replaced the EGR Valve and found out that wasn't the problem. Now I get a P0402 and I think I have it narrowed down to the pressure sensor but I need some one to confirm that for me. What do you think?

Dennis



Advertise With GS!
 
Fuel your mustang love.
Leaderboards
gotstang owns

© 2004-2015 Gostang.com

All product names are the trademarks or registered trademarks of their respective companies

gotstang.com is not affiliated with Ford Motor Company