logosmall
 
GSM# 001121
V6SSTANG
GS Newbie

1805

points

Newest Pics

updated: Oct 23rd 2006 @ 10:40 AM
Welcome to my gotstang page, here I will share with you my hobby and the 2 things I love the most, my beautiful girlfriend and my stang.
 
The current look of the car...
 
JDM Projector Headlights H1/H3, FRPP Hood Pins, CF Hood, Black GT Scoop, Cobra R Bumper, 17in Black Bullitts w/Azenis ST 115's, Ghetto Rigged Grille Delete, MGW Shiftknob, Spoiler moved back 2.5in, Dynomax Super Turbo's Side Exhaust W/X pipe, Rolled edges dual tips, CAI, GT Side Scoops, "Mustang" Third Brake Light, Window Tint, Smoked side reflectors, "pony" side emblems, wiper mod, Dual A Pillar Guages, 50% Taillight Tint
 
 
Sitting on the grass at my friends house...

My GF running away from the car LOL

Showing off my booty...

A night shot of my taillight tint...

Cruising with my friends WRX STI...

At the local meet...

At the shop getting looked at...

My GF helping me clean the cars...




Next Page


 
Page Listing
Newest Pics4116 views
Last year... (2005)1328 views
2 years ago ... (2004)1561 views

Last 3 User Comments
silverstreak02
Jun 28th, 2009 @ 11:22 PM


“”

Thanks to all who gave me advise on what to do with the sensor. Apparently it worked. The check engine light has not come on at all. I even bought the Chilton Manual to make sure I did everything right. Thanks everyone.

silverstreak02

Torch_Vert
Jun 22nd, 2009 @ 12:43 PM


“”
Replying to:

Hey Fro,

I need some help with a little problem I have. My check engine light came on, and I ran diagnostics on it and it came back with P0401. So I replaced the EGR Valve and found out that wasn't the problem. Now I get a P0402 and I think I have it narrowed down to the pressure sensor but I need some one to confirm that for me. What do you think?

Dennis


If you've already done the EGR valve, the DPFE pressure sensor is the next likely culprit

silverstreak02
Jun 22nd, 2009 @ 12:27 PM


“”

Hey Fro,

I need some help with a little problem I have. My check engine light came on, and I ran diagnostics on it and it came back with P0401. So I replaced the EGR Valve and found out that wasn't the problem. Now I get a P0402 and I think I have it narrowed down to the pressure sensor but I need some one to confirm that for me. What do you think?

Dennis



Advertise With GS!
 
Fuel your mustang love.
Leaderboards
gotstang owns

© 2004-2015 Gostang.com

All product names are the trademarks or registered trademarks of their respective companies

gotstang.com is not affiliated with Ford Motor Company